В прошлый раз мы рассмотрели решение задач типа 8 ГИА по информатике, которые рассчитаны на проверку умения исполнять линейные алгоритмы. Решение задач типа 9 ГИА по информатике подразумевает умение  исполнить  простейший  циклический  алгоритм, записанный  на  алгоритмическом язык.

Давайте рассмотрим решение задачи 9 ГИА по информатике из демоверсии 2013 года.


Запишите  значение  переменной  s,  полученное  в  результате  работы следующей  программы.  Текст  программы  приведён  на  трёх  языках программирования.

Алгоритмический язык Бейсик Паскаль
алг
нач
цел  s, k
s := 8
нц для k от 3 до 8
s := s + 8
кц
вывод s
кон
DIM k, s AS INTEGER
s = 8
FOR k = 3 TO 8
s = s + 8
NEXT k
PRINT s
Var s,k: integer;
Begin
s := 8;
for k := 3 to 8 do
s := s + 8;
writeln(s);
End.

Ответ: ___________________________.


Решение:

Итак, рассмотрим этот алгоритм, записанный на разных языках.

Вначале объявляется, что будут использованы переменные k и s целочисленного типа

Алгоритмический язык Бейсик Паскаль
цел  s, k DIM k, s AS INTEGER Var s,k: integer;

 

Далее переменной s присваивается значение 8.

Алгоритмический язык Бейсик Паскаль
s := 8 s = 8 s := 8

 

После этого описывается цикл, где в качестве параметра выступает переменная k, которая изменяется от 3 до 8 с шагом 1 (т. е. будет принимать последовательно значения 3, 4, 5, 6, 7 и 8).

Алгоритмический язык Бейсик Паскаль
нц для k от 3 до 8
s := s + 8
кц
FOR k = 3 TO 8
s = s + 8
NEXT k
for k := 3 to 8 do
s := s + 8;

 

Как видим, в теле цикла только одна команда s := s + 8. Т. е. эта операция будет выполняться на каждой итерации (на каждом шаге) цикла.

И в самом конце на экран выводится значение переменной s

Алгоритмический язык Бейсик Паскаль
вывод s PRINT s writeln(s);

В теле цикла происходит увеличение значения переменной s на 8. Так как параметр цикла увеличивается от 3 до 8 с шагом 1, то при выполнении программы тело цикла будет выполняться 6 раз ( k будет равно 3, 4, 5, 6, 7, 8). Т. е. переменная s увеличитая на 8 * 6 = 48. А так как начальное значение переменной s = 8 и после выполнения программы оно увеличится на 48, то в конечном итоге значение переменной s станет равным 56.

Ответ: 56