Поступила просьба рассмотреть подобную задачу. Итак, приступим.

Для начала создадим стартовую обстановку. Нам необходимо задать букву Н. У меня получилось вот так:

Стартовая обстановка

Стартовая обстановка

А теперь начнем писать программу. Предлагаю начать двигаться вверх. Конечно, мы можем использовать цикл с параметром, так как количество шагов вверх нам известно. Но это не правильно, мы сделаем программу универсальной — она не будет зависеть от того, как выглядит наша буква Н. Значит будем использовать цикл с условием. А условие простое — пока справа стена, мы будем двигаться вверх, закрашивая клетки.

нц пока справа стена

закрасить

вверх

кц

После этого мы получим такую картину:

Буква Н шаг 1

Буква Н шаг 1

 

Далее пойдем вправо, закрасив по пути две клетки

закрасить
вправо
закрасить

После этого нам необходимо двигаться вниз, закрашивая клетки. Но здесь условие будет другим. Мы будем опускаться, пока снизу свободно.

нц пока снизу свободно
вниз
закрасить
кц

На этом этапе мы имеем следующее:

Буква Н шаг 2

Буква Н шаг 2

Теперь нам необходимо закрасить верхнюю часть «перекладины». Для этого также в цикле будем закрашивать клетки и двигаться вправо, пока справа свободно:

нц пока справа свободно
вправо
закрасить
кц

А после этого пойдем вверх, закрашивая клетки. Условие — пока справа стена:

нц пока справа стена
вверх
закрасить
кц

Теперь сделаем шаг вправо и закрасим клетку:

вправо

закрасить

Ну а дальше все по аналогии. Приведу конечный вариант программы и то, что в итоге получается.

использовать Робот

алг

нач

нц пока справа стена

закрасить

вверх

кц

закрасить

вправо

закрасить

нц пока снизу свободно

вниз

закрасить

кц

нц пока справа свободно

вправо

закрасить

кц

нц пока справа стена

вверх

закрасить

кц

вправо

закрасить

вниз

закрасить

нц пока слева стена

вниз

закрасить

кц

влево

закрасить

вверх

нц пока сверху свободно

закрасить

вверх

кц

нц пока слева свободно

закрасить

влево

кц

нц пока слева стена

закрасить

вниз

кц

закрасить

влево

закрасить

кон

И итоговый вариант

Буква Н результат

Буква Н результат