При подготовке к ГИА по информатике для успешного решения задачи 19 из части 3 необходимо знать некоторые функции Excel. Одна из таких функций — СРЗНАЧ. Рассмотрим ее подробнее.

Функция СРЗНАЧ Excel позволяет найти среднее арифметическое аргументов. Синтаксис этой функции такой:

СРЗНАЧ(число1, [число2],…)

Не забываем, что ввод формулы в ячейку начинается со знака «=».

В скобках мы можем перечислить числа, среднее значение которых хотим найти. К примеру, если мы напишем в ячейке =СРЗНАЧ(1; 2; -7; 10; 7; 5; 9), то получим 3,857142857. Это легко проверить — если мы сложим все числа в скобках (1 + 2 + (-7) + 10 + 7 + 5 + 9 = 27) и разделим на их количество ( 7 ), то получим 3,857142857142857.

Обратите внимание — числа в скобках разделяются точкой с запятой (;). Таким образом мы можем указать до 255 чисел.

Для примеров я использую Microsort Excel 2010.

Кроме того, с помощью функции СРЗНАЧ мы можем найти среднее значение диапазона ячеек. Предположим, что у нас в диапазоне A1:A7 хранятся некоторые числа, и мы хотим найти их среднее арифметическое.

СРЗНАЧ Excel

СРЗНАЧ Excel

Давайте поместим в ячейку B1 среднее арифметическое диапазона A1:A7. Для этого устанавливаем курсор в ячейку B1 и пишем =СРЗНАЧ(A1:A7). В скобках я указал диапазон ячеек. Обратите внимание, что разделителем является символ двоеточие (:). Можно было бы поступить еще проще — написать в ячейке B1 =СРЗНАЧ( , а далее мышкой выделить нужный диапазон.

Функция СРЗНАЧ

Функция СРЗНАЧ

В итоге в ячейке B1 мы получим число 15,85714286 — это и есть среднее арифметическое диапазона A1:A7.

Excel среднее значение диапазона

Excel среднее значение диапазона

В качестве разминки предлагаю найти среднее значение чисел от 1 до 100 (1, 2, 3 и т.д. до 100). Первый ответивший в комментариях правильно получит 50р на телефон :) Работаем.