Целое число N является четным двузначным числом.

Для решения задачи необходимо проверить четность числа и его двузначность. Четность можно проверить поделив число на 2 и сравнив остаток с нулем. Для четных чисел остаток от деления всегда равен нулю. Двузначные числа — числа которые больше 9 и меньше 100. Осталось написать программу:

program u_2;
var N:integer;
begin
write('Введите число: ');
read(N);
if ((N mod 2 = 0) and ((N>9) and (N<100))) then write('Число четное, двузначное')
else write('Число не подходит');
end.
Текст задачи:
Информатика. 10 класс. Базовый уровень. (Семакин И. Г., Хеннер Е. К., Шеина Т. Ю.)
Работа 3.2, Уровень 1, Задача №2

Автор: